Current standards for FLEx on Mac

After many years running FLEx on a Mac using a VirtualBox virtual machine with, I now have an M1 Mac and can no longer use VirtualBox.

I would rather use an emulator than a real virtual machine, since I have no other need for Windows apps. But it looks like CrossOver doesn’t work with FLEx (report) and so I assume Wine doesn’t either. And if a real VM is necessary, I’d like to know which M1-compatible system works the best with FLEx (VM Fusion, Parallels, etc.) before committing.

What are people currently using for FLEx on M1 Macs?

My own IT tapped out and told me to buy a Windows computer instead - hardly a good use of money for one app.


Huh, as a non-FLEx-user myself, I wasn’t aware of this, but golly, this is a serious problem. It also seems likely to worsen with time, as many people depend on FLEx and people will gradually buy more M1 Macs. Going to link your query from Twitter as well…

In less dire news, welcome to Docling Forum, we are happy to have you here!

I recently got an M1 mac and as much as I love it, I’ve run into a few significant problems (mainly with ELAN and the custom keyboards our team uses for transcription). I do use parallels to run FLEx though and it works just fine. It’s nice and fast!

1 Like

Hi Amalia! I’m no help, I don’t have an M1 mac, but I did use flex with VM fusion for a while. I ended up buying a windows machine, partly as backup, partly to use flex. I’ve heard of many issues with M1 Macs and non-running software, unfortunately

1 Like

@MWindsor I’m surprised by the ELAN issues! I’ve used ELAN on my M1 Mac for probably 100 hours with no problem.

@cbowern I can’t say I like it, but getting a second computer seems to be the consensus - this was also the advice I got from a second IT person and another FLEx user. Looks like that is the plan


@amaliaskilton nothing is ELAN’s fault per se. We transcribe texts using Canadian Aboriginal Syllabics, but the keyboards we use (either keyman or a custom mac layout) don’t input properly to ELAN on a mac. It turns out this is a problem with Java, where there’s been a bug report sitting for years.

It would work fine to run ELAN on Windows 11 through parallels, like I do with FLEx, except that the windows version of ELAN is incompatible with the arm-based Mac M1 processor. I’m a little unclear on whether/how soon they will eventually be compatible.

So I’ve just been fumbling with weird keyboard behaviour for the past few months :frowning: .

1 Like

Just an update: parallels has a new update and ELAN now installs properly as of today :slight_smile:

1 Like

Hi Amalia! Did you find a solution to running FLEx on your Mac?

I am having the same problem, and have tried using Parallels but it doesn’t seem to work properly. It’s really frustrating!

1 Like

First I tried using an older Mac with VirtualBox, but the performance was awful. So I gave up and followed IT’s advice to buy a PC instead. Sorry nothing more useful here!

1 Like

Thanks for the feedback. It seems like I might have to follow in the PC route.

My solution to this issue was to get an old Lenovo notebook and install Ubuntu on it. That way you don’t need to run a VM, and you don’t need to buy an overpowered new machine just to run Windows. Downside: you now have a potentially heavy dedicated FLEx machine you need to carry around if you want to use FLEx.


Lenovo ThinkPads like the T530 are the bomb… $300-$400USD on ebay. Buy 8-16GB of ram… SSD I’ve been using the same one for 7 years… AMAZING…